
Welcome to PCoIP Software Client for macOS

Welcome to the Teradici PCoIP® Software Client for macOS Administrators' Guide.

PCoIP Software Clients are applications that establish PCoIP sessions with remote Windows or

Linux desktops. Connections can be made remote desktops and workstations via either PCoIP

Agents (component of Cloud Access Software) or Remote Workstation Cards.

This guide explains how to install, configure, and use the PCoIP Software Client for macOS. It

includes client system requirements and information on host dependencies.

Welcome to PCoIP Software Client for macOS
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Who Should Read This Guide?

This guide is intended for administrators and users who install, configure, or use the Teradici

PCoIP® Software Client for macOS.

Understanding terms and conventions in Teradici guides

For more information on the industry specific terms, abbreviations, text converntions, and graphic symbols used in

this guide, see Using Teradici Product and Component Guides and the Teradici Glossary.



Who Should Read This Guide?
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What's New in This Release

The PCoIP Software Client for macOS 22.01 introduces the following features and enhancements:

Security and Stability Updates

Increased security and stability updates and enhancements around the PCoIP Client.

What's New in This Release
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Additional Documentation

The following guides contain additional information relevant to PCoIP systems and PCoIP

Software Clients:

• For more information about Teradici Cloud Access Software, including detailed information on

included PCoIP components as well as Teradici All Access plans, see the Teradici Cloud

Access Architecture Guide.

• For more information about Teradici PCoIP agents, which are required on remote virtual

machines, see the following pages:

◦ Teradici PCoIP Standard Agent for Windows

◦ Teradici PCoIP Graphics Agent for Windows

◦ Teradici PCoIP Standard Agent for Linux

◦ Teradici PCoIP Graphics Agent for Linux

• For information about Teradici PCoIP Host Software, which is required on remote

workstations using a Teradici PCoIP Remote Workstation Card, see the following pages:

◦ PCoIP Host Software for Windows

◦ PCoIP Host Software for Linux

Additional Documentation
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System Requirements

The following table outlines the system requirements for the PCoIP Software Client for macOS:

*For details on feature limitations between PCoIP Software Clients and PCoIP Remote Workstation

Cards, see here. 

Hardware System Requirements

For different display configurations Teradici recommends certain processor and RAM

combinations:

• For up to dual 1920 x 1080 display configuration Teradici recommends 1.6 GHz dual core

processor or higher with at least 4 GB RAM.

• For up to dual 4K/UHD Teradici recommends a 3.0 Ghz quad core processor or higher with at

least 2 x 4 GB RAM.

System Version Required

PCoIP Software Client

Operating Systems
• macOS Catalina (10.15) Darwin v19

• macOS Big Sur (11.0) Darwin V20 This OS does not support connecting USB

devices to a remote desktop. PCoIP Ultra is not supported on devices with the

M1 chip.

Other operating systems are also supported. For information and documentation

on these, see here.

Compatible PCoIP Agents All PCoIP Agents and versions should work. Teradici recommends using the same

version of PCoIP Agent as PCoIP Client.

Compatible PCoIP Remote

Workstation Cards*

TERA22x0 with firmware 20.04 and PCoIP Host Software for Windows or Linux

20.04.

IPv Support IPv4 and IPV6 supported.

System Requirements
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Audio Support

Stereo audio output and mono audio input are supported and enabled by default.

On MacOS Catalina 10.15 configuration is required to enable microphone access on the PCoIP

Client. For information on the steps to do this, see here.

The PCoIP Client provides an enhanced audio and video synchronization (A/V Sync) feature that

provides improved full-screen video playback, reducing the difference in delays between the audio

and video channels and smoothing frame playback on the client. This improves lip sync and

reduces video frame drops for movie playback. This feature introduces a small lag in user

interaction responsiveness when enabled. Using enhanced audio and video synchronization will

reduce the maximum frame rate. For more information on enabling audio and video

synchronization (A/V Sync), see Enabling Audio and Video Synchronization.

Audio input devices should not be bridged to the remote session. Audio input devices are locally

terminated and utilize local OS audio drivers. A bluetooth headset can be supported locally, but

cannot be bridged.

For more information on the A/V Sync feature, see Enhanced Audio and Video Synchronization.

Multi-Channel Audio Output

The PCoIP Client supports multi-channel audio output when connecting to the macOS PCoIP

Graphics Agent.

Requirements

• A multi-channel audio device that supports 2.1, 5.1 or 7.1 channel configuration.

• macOS PCoIP Graphics Agent version 21.10 or newer.

• macOS PCoIP Client version 21.10 or newer.

Audio Support
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Current Limitations

• Only 2.0, 2.1, 5.1 and 7.1 channel configurations are currently supported.

• Channels must be manually mapped on the host OS to match the PCoIP Agent audio

channels. See PCoIP Graphics Agent for macOS - Mapping instructions for instructions on

mapping channels for multi-channel audio.

Enabling Multi-Channel Audio Output

After you connect your audio device to your macOS PCoIP Client, follow the instructions outlined

below to ensure it is configured as the default audio device prior to establishing your PCoIP

session:

1. From the macOS System Preferences click Sound.

2. Click on the Output tab.

3. Select the audio device you wish to make your default device.

4. Close System Preferences.

Current Limitations
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Once you have set the default audio device you can connect to your PCoIP Agent for macOS.

During session negotiation the PCoIP Agent will configure PCoIP Virtual Speakers, with the same

number of channels as your PCoIP Clients default audio device. You need to map the virtual audio

device's channels to your physical speaker layout to ensure correct speaker mapping. 

See PCoIP Graphics Agent for macOS - Mapping instructions for instructions on how to map audio

channels on your PCoIP Agent for macOS.

Enabling Multi-Channel Audio Output
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Collaboration

The PCoIP Ultra Collaboration feature enables a user to share their PCoIP session with a remote

guest collaborator using a PCoIP Software Client. While connected, the guest collaborator can

view the screen output and hear the audio output of the shared PCoIP session. 

When discussing this feature, we'll refer to the first user as the host collaborator, and the second

user who joins the session as the guest collaborator.

Enabling and Hosting a Collaboration Session

For information and steps on how to enable collaboration, and how to host a collaboration

session, see the PCoIP Graphics Agent for macOS - Enabling Collaboration and PCoIP Graphics

Agent for macOS - Hosting a Collaboration Session sections.

Joining a Collaboration Session

The guest collaborator can join the PCoIP session once they have received the PCoIP URI and the

Collaboration Invitation code from the host collaborator. For information on how to get the PCoIP

URI and Collaboration Invitation code see the PCoIP Graphics Agent for macOS guide -

Collaboration section. 

1. Open a web browser and go to the PCoIP URI shared with you (you may be able to click this

link directly, depending on how it was shared with you).

Feature Support, Requirements and Limitations

The PCoIP Ultra Collaboration feature is only supported when connecting from a Windows, Linux or macOS PCoIP

Software Client to a macOS PCoIP Graphics Agent v21.10 or later. Support for this feature on Windows and Linux

PCoIP Agents is coming in 2022, see our Technology Preview Program for further details.

The steps outlined below are intended for the guest collaborator to connect to the collaboration session. For a

complete list of requirements and limitations around this feature, see the PCoIP Graphics Agent for macOS guide -

Collaboration.



Collaboration
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2. The web browser will warn you that the link is attempting to open the PCoIP Client application.

Allow the browser to open the PCoIP Client.

3. When the PCoIP Client opens, it will prompt you for your name and the Collaboration Invitation

Code. The value you enter for your name is used to tell the host who is joining; the

Collaboration Invitation Code is the six digit number provided by the host. Enter both values

and click Submit.

4. Once the host collaborator accepts your connection request, the Collaboaration screen share

will start.

5. To leave the collaboration session, select Connection > Disconnect from the PCoIP Client

menu.

Joining a Collaboration Session
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Displays

The PCoIP Client supports a maximum of four displays and a maximum resolution of 4K UHD

(3840×2160).

Monitors can be arranged in a vertical line, a horizontal line, or as a 2×2 box display. They can be

used in any standard rotation (0°, 90°, 180°, or 270°), with any monitor as the primary display.

Note: Using multiple high-resolution displays

Systems with multiple high-resolution displays, such as quad 4K UHD topologies, require powerful system

infrastructure. Be sure to use a system with sufficient bandwidth and client capability to support your required display

topology.



Important: Attaching monitors to the host machine in not supported

PCoIP client supports a maximum of four displays. Attaching extra monitors to the host machine will conflict with

client display topologies.



Displays
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Supported Languages

The PCoIP Client supports the following languages:

• French

• German

• Spanish

• Simplified Chinese

• Traditional Chinese

• Japanese

• Portuguese

• Italian

• Korean 

• Russian

• Turkish

Supported Languages
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PCoIP Ultra

The PCoIP Client provides support for PCoIP Ultra, the latest protocol enhancements from

Teradici. PCoIP Ultra is optimized for truly lossless support with bit-exact color accuracy and

preservation of content detail at the highest frame rates.

PCoIP Ultra protocol enhancements propels our industry-recognized performance into the future

of remote computing, with faster, more interactive experience for users of remote workstations

working with high-resolution content.

PCoIP Ultra enhancements are controlled on the PCoIP Agent. There is no configuration required

on the PCoIP Client.

When to Enable PCoIP Ultra

PCoIP Ultra is apporpriate for users with the following requirements:

Auto Offload: Achieves the best balance between color accuracy and network efficiency. This

setting is appropriate for work-from-home or WAN content creators who require optimized delivery

of high resolution content, including video playback, while still achieving build-to-lossless color

accuracy.

CPU Offload: Provides efficient scaling across multicore CPUs, leveraging AVX2 instruction sets.

Appropriate for users that require CPU-optimized delivery of 4K UHD, high-framerate video

playback and build-to-lossless color accuracy. It is also useful when GPU encoding resources must

be reserved for video encoding applications, typically in LAN environments.

GPU Offload: PCoIP encoding is always offloaded to a GPU. Appropriate for users who demand the

highest possible CPU efficiency.

For all other scenarios, Teradici recommends that you leave PCoIP Ultra disabled.

PCoIP Ultra is appropriate for specific use cases

For most users, the default PCoIP protocol will provide the best possible experience. Carefully review the

recommended use cases in the next section to determine whether you should enable it.



PCoIP Ultra
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Requirements

To take advantage of PCoIP Ultra, you need:

• A PCoIP Agent (any type), 21.03 or later

• A PCoIP Software Client (any type), 21.03 or later

• The CPUs on both the agent and the client machines must support the AVX2 instruction set.

Enabling PCoIP Ultra

In order to enable PCoIP Ultra features you need to turn on GPO variables in the PCoIP Agent. For

information on enabling this with Linux, see Enabling PCoIP Ultra for Linux. For information on

enabling this with Windows, see Enabling PCoIP Ultra for Windows. 

PCoIP Codec Indicator

When enabling PCoIP Ultra there will be an onscreen indicator at the bottom left corner of the

screen. PCoIP Ultra CPU optimization is indicated with a dark blue dot. PCoIP Ultra GPU

optimization is indicated by a magenta dot. 

To enable the PCoIP Codec Indicator create a file called ~/.pcoip.rc, if it does not already exist, and

add the following line:

To disable this codec update the  parameter: 

pcoip.codec_indicator = 1

pcoip.code_indicator

~/.pcoip.rc pcoip.codec_indicator = 0 

Requirements
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Printing Support

When a local printer is visible to a client computer by USB connection or local network connection,

it may be possible to print from the host machine. Refer to the following table for local printing

support.

The following are the printing options available with the PCoIP Client:

• Local USB Printing: Printing to a USB printer locally attached to the Client device.

• Remote Network Printing: Enables printing to a network printer on the nost machines

network. Not suitable in situations here the PCoIP Software Client device is not on the same

network as he host device.

• Cloud Printing: This is access to external Cloud Services that are set-up on your local

workstation and network. Once these services have been correctly configured they can be

used by the PCoIP Software Client.

• Local Network Printing: Enables printing from the host machine to a printer in the PCoIP

Client machine's local area network. This method is suitable for printing when host and client

are not on the same network or for identifying and printing to local printers that exist in multi-

site organizations.

The PCoIP Standard Agent for Linux does not support local printing on remote clients.

PCoIP Agent for Windows PCoIP Agent for Linux

Local USB Printing  

printer is connected to a USB port on the client computer

—

Remote Network Printing  —

Local Network Printing  —

Cloud Printing  —

Printing Support
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Local, network, and cloud printers are supported in various ways:

• Linux hosts can print to any printer on the host machine’s local area network.

• If your host host workstation has access to the Internet, cloud-based printing is supported

through cloud-printing services such as Google Cloud Print and HP Mobile Printing.

Printing Support
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USB Support

PCoIP Clients supports redirecting USB devices to a remote session. Administrators can set rules

governing allowed and disallowed devices, device classes, or device protocols. 

Remote USB Device Support

If a pointer type USB device, for example wacom tablets, mouse, or stylus device, is remoted, you

need to grant PCoIPClient.app computer control to enable it to rendor and move the cursor. You

can enable this through the Preferences>Security & Privacy>Privacy>Accessibility location on

your system settings.

Isochronous USB device Support

Some USB devices with time-sensitive information, such as webcams, are supported when

connecting to the PCoIP Agent for Windows.

Additionally, Teradici's technology partners provide solutions to expand peripheral support. For

more information, look for partners listed under Peripherals on the Teradici Technology Partners

page.

Important: USB support is enabled by default

USB bridging is enabled by default. If you want to restrict or disable USB support, you can globally disable or set rules

governing USB behavior via GPO settings on the PCoIP Agent.



USB Redirection

USB redirection is only intended to be used with a single instance of the PCoIP Software Client. Launching a second

instance of the PCoIP Software Client while USB devices are redirected from another client may not work as expected.



USB Support
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USB Device Pressure Sensitivity

The PCoIP Software Client for macOS may encounter issues with Wacom pressure sensitivity.

This is as a USB handling restriction on macOS Catalina. It occurs when you want to load the USB

Kernel Extension at session start up. For information on how to address this issue, see here.

USB Device Pressure Sensitivity
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Wacom Tablet Support

The Software Client for macOS supports Wacom tablets in two configurations: bridged, where

peripheral data is sent to the desktop for processing, and locally terminated, where peripheral data

is processed locally at the Software Client.

Locally terminated Wacom tablets are much more responsive and tolerate low latency

connections. 

Whether the Wacom tablet is locally terminated or bridged, the process of remoting the USB

device is the same, you need to click connect in the USB menu or auto forward the device. If local

termination is supported for the particular device, it will automatically be chosen over bridging. For

more information on this, see Local Termination Blacklist.

Remote USB Device Support

If a pointer type USB device, for example wacom tablets, mouse, or stylus device, is remoted, you

need to grant PCoIPClient.app computer control to enable it to rendor and move the cursor. You

can enable this through the Preferences>Security & Privacy>Privacy>Accessibility location on

your system settings.

Locally Terminated Wacom Tablets

Locally-terminated tablets have greatly improved responsiveness, and tolerate higher-latency

(including 25ms and higher) networks.

Local termination requires:

• A Standard agent or Graphics agent for Windows version 21.01 or higher.

• A Standard agent or Graphics agent for Linux version 21.01 or higher.

The following Wacom tablet models have been tested and are supported with local termination.

PCoIP client support for locally terminated Wacom tablets and the Software Client for macOS

Wacom Tablet Support
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PCoIP

Standard

Agent for

Linux

PCoIP

Graphics

Agent for

Linux

PCoIP

Standard

Agent for

Windows

PCoIP

Graphics

Agent for

Windows

PCoIP Remote

Workstation

Card

Intuos Pro Small

PTH-460

    —

Intuos Pro Medium

PTH-660

    —

Intuos Pro Large

PTH-860

    —

Cintiq 22HD

DTK-2200

— — — — —

Cintiq Pro 24 -

 Pen Only

DTK-2420

    —

Cintiq 22

DTK-2260

    —

Cintiq 22HDT -

 Pen & Touch

DTH-2200

— — — — —

Cintiq Pro 24 -

 Pen & Touch

DTH-2420

— — — — —

Cintiq Pro 32 -

 Pen & Touch

DTH3220

    —

Locally Terminated Wacom Tablets
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Bridged Wacom Tablets

Bridged Wacom tablets are supported only in low-latency environments. Tablets in network

environments with greater than 25ms latency will show reduced responsiveness and are not

recommended.

The following Wacom tablet models have been tested and are supported on a PCoIP Software

Client for Mac.

PCoIP client support for bridged Wacom tablets and the Software Client for Mac

PCoIP

Standard

Agent for

Linux

PCoIP

Graphics

Agent for

Linux

PCoIP

Standard

Agent for

Windows

PCoIP

Graphics

Agent for

Windows

PCoIP Remote

Workstation

Card

Intuos Pro Small

PTH-460

    —

Intuos Pro Medium

PTH-660

    —

Intuos Pro Large

PTH-860

    —

Cintiq 22HD

DTK-2200

    —

Cintiq Pro 24 -

 Pen Only

DTK-2420

    —

Cintiq 22HDT -

 Pen & Touch

DTH-2200

    —

Cintiq Pro 24 -

 Pen & Touch

DTH-2420

    —

Bridged Wacom Tablets
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Known Issues with Wacom Tablets and Functionality

Whilst testing and developing the compatibility of Teradici Cloud Access Software with different

Wacom tablets, certain performance issues arise. The following is a list of the current known

issues with certain Wacom tablets:

• The touch feature does not work on any supported device for both bridged and locally

terminated devices across all platforms.

• ExpressKey Remote does not work on the Wacom Cintiq Pro 32 (DTH-3220). You should still

remote to this device when remoting to the Wacom tablet.

• There are cursor limitations when working with the Wacom Cintiq 22HD (DTK-2200) and

Wacom Cintiq Pro 24 (DTK-2420) for both bridged and locally terminated devices across all

platforms.

• There is a issue with the control buttons on the Wacom Cintiq Pro 32 (DTH-3220) device. The

buttons do not function on locally terminated devices across all platforms.

• PCoIP Clients are not compatible with NoMachine and No Machine USB drivers. For

information on how to uninstall NoMachine USB drivers, see here.

PCoIP

Standard

Agent for

Linux

PCoIP

Graphics

Agent for

Linux

PCoIP

Standard

Agent for

Windows

PCoIP

Graphics

Agent for

Windows

PCoIP Remote

Workstation

Card

Cintiq Pro 32 -

 Pen & Touch

DTH3220

    —

Cintiq 22HD Wacom Driver

The Cintiq 22HD may require the Wacom driver to be installed on both the PCoIP Agent and PCoIP Client. The driver

version on the PCoIP Agent must be 6.3.32-4. The driver on the PCoIP Client must be the latest version available.



Known Issues with Wacom Tablets and Functionality
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USB Device Pressure Sensitivity

The PCoIP Software Client for macOS may encounter issues with Wacom pressure sensitivity.

This is as a USB handling restriction on macOS Catalina. It occurs when you want to load the USB

Kernel Extension at session start up. For information on how to address this issue, see here.

Wacom Cintiq Pro 32 Tablet Selection

The Wacom Cintiq Pro 32 shows up as multiple devices in the USB menu. You should remote the

following USB devices as outlined in the image below to remote to this Wacom tablet:

• ExpressKey Remote

• Cintiq Pro 32 Touch

• Wacom Cintiq Pro 32

USB Device Pressure Sensitivity
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Console Game Controller Support

PCoIP Software Clients are compatible with the following console game controllers:

• PS4

• PS5

• Logitech F310 gamepad

The following console game controllers are supported with the PCoIP Zero Client:

• Xbox One 2015

• Xbox One

• Xbox One S

• Xbox One Bt

• Xbox One Elite

Console Game Controller Support
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Installing the PCoIP Software Client for macOS

In this section, you'll learn how to install and uninstall the PCoIP Software Client for macOS.

Before You Begin

Before installing a PCoIP Software Client:

• You must be logged in as an administrator to the client machine.

• Close any existing PCoIP Software Client applications.

Installing the PCoIP Software Client

To install the PCoIP Software Client:

1. Copy the PCoIP Software Client disk image file PCoIPClient.dmg to your desktop.

2. Double-click the file to mount the volume.

3. Accept the license agreement by clicking Agree.

4. In the PCoIPClient volume window, drag the PCoIPClient icon into the Applications folder icon

to install the program.

5. To optionally create an alias on the desktop or the dock:

• Double-click the Applications folder icon to open the folder.

Installing the PCoIP Software Client for macOS
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• Drag the client application to the desktop or dock.

6. To eject the volume when you are finished, drag it to the trash.

To uninstall the PCoIP Software Client:

• Navigate to the Applications folder and drag the PCoIPClient program to the trash. Or, right-

click the application and select Move to Trash.

Installing the Software Client in Silent Mode

The following section outlines how to install the PCoIP Software Client in silent mode. Please note

that you must authorize the application to run in silent mode. To install the PCoIP Software Client

on macOS in silent, run the following commands:

1. Attach the  file: 

2. Delete the current PCoIP Client: 

3. Install the new PCoIP Client: 

4. Unmount the drive afterwards: 

Troubleshooting PCoIP Session Connection Issues

If you encounter issues with your PCoIP Session, please see the following KB article: https://help.teradici.com/s/

article/1027. This article details some potential causes and fixes for common connection issues.



.dmg

yes | hdiutil attach <pcoip client installer>.dmg 

rm -R '/Applications/PCoIPClient.app'

cp -R '/Volumes/<pcoip client installer>/PCoIPClient.app' /Applications

yes | hdiutil unmount <pcoip client installer>

To uninstall the PCoIP Software Client:
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Using the PCoIP Software Client

After installing a PCoIP Software Client on your client machine, you can connect to the following

PCoIP solutions or products or hosts:

• Teradici PCoIP Graphics Agent or PCoIP Standard Agent installed as part of Teradici Cloud

Access Software.

• Teradici PCoIP Remote Workstation Card and Teradici PCoIP Host Software installed in a

Windows or Linux workstation.

• If you want to connect to the PCoIP Remote Workstation Card you need to install the PCoIP

Remote Workstation Card Agent along with PCoIP Host Software.

Using the PCoIP Software Client
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Connecting to Virtual Machines

You can connect to virtual Windows or Linux hosts that have a PCoIP Standard Agent or PCoIP

Graphics Agent installed. Connections can be made directly to individual host machines, or via a

connection broker in managed deployments.

To connect to a remote workstation or virtual desktop:

1. Double-click the PCoIP Client desktop icon, alias, or program file PCoIPClient to launch the

application.

2. In the Host Address or Code field, enter one of the following:

• For direct connections, provide the address of the host machine.

• For managed connections, provide the address of the connection manager. 

If you want to save this connection later for easy recall, enter a name in the Connection Name

field. You will save the connection in step 5.

3. Click NEXT.

Connecting to Virtual Machines
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4. On the next screen, select your domain from the dropdown list, enter your user name and

password for the desktop, and then click LOGIN. 

About the Security Padlock Indicator

The login screen displays a red padlock indicator when accessing a PCoIP agent desktop that uses default self-

signed certificates. The icon indicates that the software’s certificate is not signed by a trusted certificate

authority (CA). You can use your own CA to create a certificate and then install the appropriate files at each end.

If the client trusts your internal CA, a green padlock icon displays on the screen instead. To learn more about

certificates, see the PCoIP agent administrators guides listed in the Teradici Cloud Access Architecture Guide.
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5. If your login is successful, the following screen appears with a list of available desktops: 

6. Click Connect to connect to the selected desktop.

A short interface delay is normal

When a session is first connected, it may take a few seconds before you can take control of the keyboard and mouse.

This is normal behavior.



Single-desktop users

If a user only has access to a single desktop, that desktop is automatically selected and the connection is initiated

immediately. These users are not presented with a desktop selection screen.



To connect to a remote workstation or virtual desktop:
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Advanced Saved Connections

Administrators can save more complex desktop connections with the PCoIP Client. The following

section outlines the connection scenarios that can be saved, and outlines the potential benefits of

doing so.

Saved Broker Address

This configuration enables you to create a saved connection where only the broker address is

saved. You need to enter your username when connecting to a remote host. Enter the host

address and name the connection, then click SAVE.

For more information on system components and connections using a broker, see About PCoIP

Sessions section in the macOS Client SDK guide.

Pre-configured connections

This partial save feature enables administrators to pre-configure connection information as a saved connection and

bundle it with the client application. For example, administrators can save a connection with the FQDN of the PCoIP

Connection Manager preset and then distribute this information to their deployed clients. As a result of this users

would be able to skip past the initial domain screen and advance directly to their user authentication screen.

The administrator can find and distribute the connection info file located at $HOME/Library/Preferences/

com.teradici.PCoIP\ Client\ Connection\ Info.plist



Advanced Saved Connections
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Multiple Desktops

This configuration enables you to see and access a selection of desktop environments each time

you connect. 

1. Enter the host address and name the connection 

2. Enter and save the Username 

Multiple Desktops
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Once you have done this each time you use this connection you will be presented with the list of

available desktops for that connection. 

Multiple Desktops
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Connecting to Teradici PCoIP Remote Workstation
Cards

You can connect to remote workstations with a Teradici PCoIP Remote Workstation Card and

PCoIP Host Software installed. Refer to System Requirements for supported versions.

Initial Workstation Configuration

Before you can connect to your remote workstation for the first time, a few things must be

configured on the host machine.

These configuration actions only need to be taken once on each remote workstation in your

system:

• Record the MAC address of the PCoIP Remote Workstation Card

Before you install the PCoIP Remote Workstation Card in the workstation, record the MAC

address of the PCoIP Remote Workstation Card as this will will enable you to log into the card

to configure the settings. Type https://pcoip-host-0030040de898.mydomain where

0030040de898 is the MAC address of your PCoIP Remote Workstation Card and mydomain is

the local domain of your network. This step is important as the host driver function is disabled

by default, so the host software will not pick up information about the PCoIP Remote

Workstation Card, such as the MAC address. The MAC address enables you to connect to the

PCoIP Remote Workstation Card to view the IP address and enable the host driver function. 

For more information on IP and MAC information relating to the PCoIP Remote Workstation

Card, see here.

• Install PCoIP Remote Workstation Card Agent

To connect to a remote workstation with a PCoIP Remote Workstation Card using a PCoIP

Software Client, the Remote Workstation Card Agent must be installed.

• Enable monitor emulation for the video ports on your remote workstation

If monitor emulation is not enabled, you may see blank gray screens when you connect from

the PCoIP Software Client.

Connecting to Teradici PCoIP Remote Workstation Cards
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To enable monitor emulation, log in to the card’s Administrator Web Interface (AWI) and select

Enable Monitor Emulation on Video Port n from the Configuration > Monitor Emulation menu.

For more information, see the Tera2 PCoIP Zero Client Firmware 4.x and Remote Workstation

Card Firmware 4.9 Administrators' Guide.

• Disable temporal dithering

Temporal dithering causes blurriness, heavy packet loss, and high CPU usage on the PCoIP

Software Client machine. See Should I disable the dithering feature of my graphics card in a

remote workstation environment? (KB 15134-207) for more information.

• Linux workstations: configure PCoIP Host Software to Start Automatically

To configure the PCoIP host software to start automatically, log into the workstation using a

PCoIP Zero Client or directly from a local mouse and keyboard, and modify the workstation

startup script to launch the PCoIP host software. For details, see Installing PCoIP Host

Software Binary RPM in the PCoIP® Host Software for Linux User Guide.

Connecting to a Remote Workstation Card

Once the remote workstation is properly configured, you can connect to it from the PCoIP

Software Client.

Connecting to a Remote Workstation Card via a PCoIP Software Client

The direct connection from the PCoIP Software Client to the PCoIP Remote Workstation Card is

supported through the PCoIP Remote Workstaton Agent software which needs to be installed on

the workstation where the PCoIP Remote Workstation Card is installed. You must have a Remote

Workstation Card Agent installed to enable a connection to a Remote Workstation Card.

Both the NIC of the workstation and the NIC of the PCoIP Remote Workstation card need to be

accessible by the PCoIP Software Client. They can be on different local networks as long as both

are accessible by the PCoIP Software Client. If they are both behind a NAT and accessed by the

Workstation configuration is required before connecting

If you experience connection problems or degraded performance, make sure that the workstation is configured as

described in Initial Workstation Configuration.
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PCoIP Software Client then the PCoIP Remote Workstation Card Agent must send the NAT'ed

address to the PCoIP Software Client when connecting.

Connecting to a PCoIP Remote Workstation Card through the command line

You can have a direct connection to a PCoIP Remote Workstation card, from a PCoIP Software

Client, without requiring a PCoIP Remote Workstation Card agent installed on the host machine if

you connect via the command line by using the  option with the IP address of your

PCoIP Remote Workstation Card, for example:

10.11.12.13 is the IP address of the PCoIP Remote Workstation Card.

Connecting to a remote workstation with a Teradici PCoIP Remote Workstation

Card installed:

1. Double-click the PCoIP Client desktop icon, alias, or program file (PCoIPClient) to launch the

application.

Cloud Access Software Subscription

You need to have a valid Cloud Access Software Subscription to use the PCoIP Remote Workstation Card Agent.



Direct Connection to PCoIP Remote Workstation Cards

PCoIP brokering can now be used to connect to the Remote Workstation Card. You can still connect to a non-

brokered Remote Workstation Card by connecting to the FQDN of the workstation instead of the FQDN of the Remote

Workstation Card. This method of connection requires the Remote Workstation Card Agent to be installed on the

workstation



--hard-host

/Applications/PCoIPClient.app/Contents/MacOS/PCoIPClient --hard-host 10.11.12.13

Connecting to a PCoIP Remote Workstation Card through the command line
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2. In the Host Address and Code box, enter the fully-qualified computer name or IP address of

the remote workstation or the address of the PCoIP broker, for example Cloud Access

Manager or a third-party broker.

3. Optional: In the Connection Name box, enter a name for your connection. This field accepts

any Unicode character.

4. Click NEXT.

5. If your desktop is locked upon connection and requires you to enter Ctrl+Alt+Delete to log in,

select Connection > Send CTRL-ALT-DEL from the PCoIP Software Client menu bar.

PCoIP Remote Workstation Card Feature Compatibility

Not all features with the Software Client are fully supported when connecting to a PCoIP Remote

Workstation Card. The following section outlines these limitations against certain features.

Audio: PCoIP Remote Workstation Card uses a hardware based audio protocol which is not fully

supported on the Software Client.

The Connection Information can be saved

If you provide a connection name now, you will have the option of saving the connection after you are

authenticated. Saved connections can be quickly recalled later, without manually re-entering connection

information.



A short interface delay is normal

When a session is first connected, it may take a few seconds before you can take control of the keyboard and

mouse. This is normal behavior.



PCoIP Remote Workstation Card Feature Compatibility
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Topology: Single display configuration will work. There may be disruptions in the forms of black

bars or scroll bars on the client if the PCoIP Remote Workstation Card does not support the

display configuration on the client. The worst instance of this disruption will occur for some client

configurations that don't work with the hard host configuration.

USB: Connecting USB devices to the PCoIP Remote Workstation Card is not supported.

Performance: Updated to support PCoIP Ultra are not applicable to the RWC.

Connecting Remotely using NAT or VPN

The same principles that apply for PCoIP Zero Clients apply to PCoIP Software Clients when

connecting to multiple hosts through a WAN. Connections from a PCoIP Software Client to a

Remote Workstation Card across a WAN will require a VPN or NAT setup with enterprise level

NATing devices. For information on how to connect a PCoIP Software Client to a Remote

Workstation Card installed in a Windows host computer, see here.

Connecting Remotely using NAT or VPN
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Connecting to a USB Device

Remote Windows hosts using the PCoIP Standard Agent or the PCoIP Graphics Agent can use

USB devices that are attached to the client. When you connect a local USB device to your remote

host it will be disabled on the client machine.

USB device connections do not persist across multiple PCoIP sessions. You must connect your

USB device each time you connect.

The following section outlines how to connect a USB device:

1. Attach the USB device you want to connect.

2. Select Connection > USB Devices from the PCoIP Software Client menu.

PCoIP Agent needs to be configured to enable USB redirection

The USB menu will only show up if the PCoIP Agent has been configured to enable USB redirection and a USB device

has been detected by the PCoIP Client.



One-time PCoIP Software Client for macOS login

The first time you connect after a Mac installation, you must enter a Mac administrator user name and password. You

only need to do this when you install a new client.



ePadLink Signature Pad and some Wacom tablets are connected via local termination

If you are using an ePadLink Signature Pad and certain Wacom tablets they can be connected via local termination.

You do not need to carry out any other steps to establish this connection. For information on which Wacom tablets

are locally terminated, see Wacom Tablets.



NoMachine USB Driver Compatibility

PCoIP Clients are not compatible with NoMachine and No Machine USB drivers. For information on how to uninstall

NoMachine USB drivers, see here.



Connecting to a USB Device
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A list of USB devices connected to your client machine appears. Integrated USB devices, such

as built-in cameras on laptops, will appear in this list along with devices you have plugged in

yourself.

Some devices will identify themselves only as USB Device.

3. Click Connect beside the USB device you want to use. 

Disconnecting a USB Device

1. Select Connection > USB Devices from the PCoIP Software Client menu.

Connecting to Human Interface Devices

Most Human Interface Devices (HIDs), such as keyboards and mice, are automatically handled by the PCoIP Software

Client and don't appear on in this list even if they use a USB connection.

If you need to connect a Human Interface Device that can't be locally processed, like a 3D mouse or a Wacom tablet,

enable the Show Human Interface Devices checkbox to reveal the device in the USB device list and click its Connect

button.

You may also have to complete additional configuration steps or install drivers on the host machine.



Disconnecting a USB Device
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2. Click Disconnect beside the USB device you want to disconnect. 

USB Auto-Forward for Non-HID Devices

A HID is a device class definition that enables a generic USB driver to support devices such as

keyboards, mice, tablets, controllers, etc. Non-HID devices primarily run on the PS/2 port transport.

Automatic bridging enables you to auto bridge all non-HID USB devices by using the 

 command line parameter.

USB Vendor ID/Product ID Auto-Forward

You can automatically forward up to 20 USB devices to the host at the start of the session by

calling the PCoIP client executable with  and the required VID/PID pairs. 

usb-auto-

forward

vidpid-auto-forward

USB Auto-Forward for Non-HID Devices
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USB VID/PID Auto-forwarding workflow

Devices that are auto-forwarded will appear in the USB Devices dialog box, enabling users to

connect or disconnect them from the host. The PCoIP Client application is located at 

PCoIPClient.app/Contents/MacOS. The following is an example of how this command would look

with the VID/PID values: 

The following rules apply to VID and PID values:

• VID/PID values are comma-separated: ,

• VID/PID pairs are space-separated:  

• VID/PID pairs with invalid values will be discarded. Discarded rules appear in the event log.

• Up to 20 devices will be passed; if more than 20 are attempted, the first 20 will be accepted

and rest ignored. Ignored rules appear in the event log.

VID/PID Pairs

You can locate the VID/PID pairs from the PCoIP Client logs which are placed in ~/Library/Logs/Teradici/

PCoIPClient. When getting the VID/PID pairs from the log you need to strip 0x from the IDs, and use the rest of the

ID when running the  command. As outlined in the following example: 

The VID/PID pair in this scenario would be 18a5,0302.



vidpid-auto-forward

2040-12-12T20:36:46.117Z e0f9e9e9e-866f-1038-test-ac87a3007abc LVL:2 RC:   0        
MGMT_USB :Device 0x00010001 VID=0x**18a5**PID=0x**0302**
2040-12-12T20:36:46.117Z e0f9e9e9e-866f-1038-test-ac87a3007abc LVL:2 RC:   0        
MGMT_USB :Device 0x00010001 Name=TEST Serial=012345ABCDE pp=000222222

./PCoIPClient --vidpid-auto-forward "1234,5678 abcd,efgh"

xxx yyy

aaa,bbb ccc,ddd

USB Vendor ID/Product ID Auto-Forward
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Configuring Wacom Tablets

This section outlines how to configure your Wacom tablet through the PCoIP Client session. There

are two available features within the PCoIP Client that can be used to configure the monitor

display and orientation.

Wacom Tablet Monitor

The Tablet Monitor feature enables you to select the monitor you want to use with your Wacom

tablet. You can change between using a pen or mouse and select the orientation position.

To configure Tablet Monitor settings:

1. Select View from the in-session options bar.

2. Check the Tablet Monitor option.

3. Open Wacom Tablet Properties from the Wacom Desktop Center.

4. Select your device, tool and application.

5. Select your screen area from the dropdown menu.

USB Connection Instructions

Before you carry out the Wacom tablet monitor configurations below, you must connect to the device by following the

instructions outlined in the Connecting to USB Devices section.



Configuring Wacom Tablets
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Wacom Tablet Monitor
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Tablet Orientation Left-handed

The left-handed orientation configures the tablet for a left-handed orientation. Select ExpressKeys

Right for a left-handed orientation, and ExpressKeys Left for a right-handed orientation. Rotate the

tablet to the desired orientation.

To configure Tablet Orientation:

1. Select View from the in-session options bar.

2. Check the Tablet Orientation Left-handed option.

3. Open Wacom Tablet Properties from the Wacom Desktop Center.

4. Select your device, tool and application.

5. Select your orientation from the dropdown menu.

Tablet Orientation Left-handed
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Using Saved Connections

Once you have saved a connection, you can use it to reconnect easily.

To reconnect using your saved connection:

1. Click the button for the saved connection. The button label displays the connection name you

assigned when you configured the connection. 

2. To see the connection address, hover your mouse over the saved connection. Hovering over a

saved virtual desktop will also show the desktop name. 

Using Saved Connections
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3. To edit or delete a saved connection, click the configure button on the right, and then select

the desired option from the popup menu. 

4. If you have saved multiple connections, click the desired one to reconnect. If you have multiple

saved connections use the search bar to locate the connection and scroll down to find it. 

5. Any time you wish to connect to a new workstation, just click NEW CONNECTION to return to

the main screen, and then enter the connection details.

To reconnect using your saved connection:
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Filtering through your saved connections

You can use the search bar to now filter saved connections based on there connection names. 

Filtering through your saved connections
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Reset Virtual Desktop

The following section outlines how to reset a saved desktop in the PCoIP Client. You can reset to a

virtual desktop by following the steps outlined below:

1. Click the configure button and select Edit from the popup menu. 

2. Click NEXT on the initial saved connection screen. 

Reset Virtual Desktop
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3. Enter your access credentials and click SAVE. 

4. Click the configure button and select Reset. If the Reset option is not available, then this

feature is not supported by the Connection Manager. 

Reset Virtual Desktop
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Disconnecting a Session

To disconnect a PCoIP session, select the Connection > Disconnect menu option.

Quitting the PCoIP Client application will also disconnect the current session.

Session Reconnection

If a network interruption is detected, the PCoIP session enters a reconnecting phase. In this phase

the client will show you the network reconnecting dialog which indicates that there is a network

issue and that the client is trying to reconnect and re-establish the PCoIP session. You can click 

disconnect to cancel the attempted reconnect and disconnect the session completely. If the

reconnection is successful, the notification dialog will disappear and the session will be restored, if

not, the session will be disconnected completely.

Quickly Disconnect from a session

To quickly disconnect from a session, press CTRL+Option+F12



Disconnecting a Session
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Changing the PCoIP Software Client Window Mode

You can use the PCoIP Software Client in full-screen or windowed mode. Full-screen mode is

recommended in most cases.

Activating Full Screen Modes

The PCoIP Software Client provides two full-screen modes: one monitor and all monitors.

To switch from windowed mode to full-screen mode:

• To use one full-screen display, select View > Show Fullscreen One Monitor.

All open windows and applications will be moved to a single full-screen display. This is

equivalent to disconnecting all but one monitor from a physical host.

• To use all available full-screen displays, select View > Show Fullscreen All Monitors.

This mode shows full-screen displays on all client monitors.

To switch from Fullscreen One Monitor to Fullscreen All Monitors mode:

1. Reveal the menu bar by moving the mouse cursor to the top of a client display.

2. Select View > Show Fullscreen All Monitors.

To switch from Fullscreen All Monitors to Fullscreen One Monitor mode:

1. Reveal the menu bar by moving the mouse cursor to the top of a client display.

2. Select View > Show Fullscreen One Monitor.

Keyboard shortcut

You can also enter full-screen mode by pressing Ctrl+Option+Return while in windowed mode. The shortcut will

activate whichever full-screen mode was used last, or all monitors if no previous selection was made.



Changing the PCoIP Software Client Window Mode
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Miminizing the PCoIP Software Client from a Full-screen Mode

To minimize a software client in full-screen mode:

1. Reveal the menu bar by moving the mouse cursor to the top of any display.

2. Select View > Minimize Client.

Activating Windowed Mode

To switch from full-screen mode to windowed mode:

1. Reveal the menu bar by moving the mouse cursor to the top of any display.

2. Select View > Leave Fullscreen.

Persistent Display Topology

Depending on the display topology mode you have selected, for example Fullscreen One Monitor, if you disconnect

and then reconnect to the session, it will maintain that same mode upon reconnection. The state and mode will be

preserved.



Keyboard shortcut

You can also minimize the client by pressing Ctrl+Option+m while in any full-screen mode.



Keyboard shortcut

You can also enter windowed mode by pressing Ctrl+Option+Return while in any full-screen mode.



Miminizing the PCoIP Software Client from a Full-screen Mode
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Detect Monitors

The detect monitors feature enables you to add and remove displays from the desktop through the

PCoIP Client while in an active session.

Adding a Display

The following steps outline how to add a display to your desktop through the PCoIP Client:

1. Connect a new monitor to the client.

2. From the desktop, click View.

3. Click Detect Monitors.

4. Select the monitor you want to add.

The displays on the remote desktop will be extended to include the new monitor.

Removing a Display

The following steps outline how to remove a display from your desktop.

1. Disconnect a monitor from the client.

2. From the desktop, click View.

3. Click Detect Monitors.

You will no longer see the monitor that you have disconnected from the client.

Detect Monitors
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Enhanced Audio and Video Synchronization

Enhanced Audio and Video Synchronization provides improved full-screen video playback,

reducing the difference in delays between the audio and video channels and smoothing frame

playback on the client. This improves lip sync and reduces video frame drops for video playback.

This feature introduces a small lag in user interaction responsiveness when enabled. Using

enhanced audio and video synchronization will reduce the maximum frame rate.

Enhanced A/V Sync is enabled on a per-display basis, so you can dedicate individual displays to

playback without impacting responsiveness on the others.

To use enhanced A/V Sync:

1. If you are in full-screen mode, reveal the menu bar on the display you want to enhance by

moving the mouse cursor to the top of the screen.

2. On the display you want to enhance select View>Enhanced A/V Sync to toggle the enhanced

sync mode.

PCoIP Ultra AV-Lock

PCoIP Ultra AV-Lock enables regulated synchronization of audio and video frames. When audio is

playing the video frames will be delayed to align with the audio sound track. When there is no

audio playing the video frames will be presented to the user without delay. In some use cases,

such as video editorial, audio video synchronization, it must be tolerant of variable network

conditions that may be present with remote work.

PCoIP Ultra AV-Lock enables more regulated synchronization of audio and video frames compared

to Enhanced A/V Sync that's described above. PCoIP Ultra AV-Lock is available with PCoIP Ultra

CPU Offload, GPU Offload or Auto Offload. You must enable the High Performance Client mode for

Persistent Display Topology

The Enhanced Audio and Video Synchronization feature is persistent across sessions from the same client, provided

that the display topology has not changed.



Enhanced Audio and Video Synchronization
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this feature to function correctly, for instructions on how to activate this High Performance Mode,

see PCoIP High Performance Client. 

To activate Ultra AV-Lock from the High Performance Client menu, under the menu "View - PCoIP

Ultra AV-Lock", select the monitor you wish to activate Ultra AV-Lock on. Monitors with Ultra AV-

Lock activated will be indicated with a checkmark in the menu. This may be switched on/off for

individual monitors in-session, and will be remembered for future sessions as long as the monitor

topology remains the same.

PCoIP Ultra AV-Lock
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Sending a Ctrl-Alt-Del Command

To send the Ctrl-Alt-Del keyboard command to a remote workstation, select the Connection >

Send CTRL-ALT-DEL menu option.

Sending a Ctrl-Alt-Del Command
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Changing the Language

In addition to English, the PCoIP Software Client also supports these languages: Chinese

(Simplified), French, German, Italian, Japanese, Korean, Portuguese (Brazil), Portuguese (Europe),

Russian, Spanish, and Turkish. During installation, you can select one of the supported languages.

To change the language after installation:

• In System Preferences > Language & Region > Advanced > General tab, select another

language in the Format language list.

To change the language on the command line

Alternatively, the language can be set with the  parameter on the command line:

The following table lists the available language translations and codes:

locale

pcoip-client --locale <locale-code>

Language Code

German de

Spanish es

French fr

Italian it

Japanese ja

Korean ko

Portuguese (EU) pt

Portuguese (Brazil) pt_BR

Changing the Language
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Language Code

Russian ru

Turkish tr

Chinese (Simplified) zh_CN

Chinese (Traditional) zh_TW

Changing the Language
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System Precedence

The following section outlines the scope precedence commands between the User Scope and 

System Scope. If you are updating individual user settings then the user scope locations and

parameters can be followed. Due to this order of precedence where by the user scope setting

takes precedence over the system scope setting, a change in the system settings may not take

effect if the user scope setting has been updated.

User Scope

Within the user scope the .plist files are located in ~/Library/Preferences/. The following

commands detail the read, delete and write functions:

System Scope

The .plist files are located in /Library/Preferences/. The following commands detail the read,

delete and write sudo functions:

defaults read "com.teradici.Teradici PCoIP Client" <Key>

defaults "com.teradici.Teradici PCoIP Client" <Key>

defaults write "com.teradici.Teradici PCoIP Client" <Key> <value>

Re-boot Requirement

The macOS machine may require a re-boot for the system configuration to take effect.



sudo defaults read "/Library/Preferences/com.teradici.Teradici PCoIP 
Client.plist" <Key>

sudo defaults delete "/Library/Preferences/com.teradici.Teradici PCoIP 
Client.plist" <Key>

System Precedence
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Enabling remap_cmd_to_ctrl Setting

The  setting is a pre-existing setting which controls whether the command

key would map to Control, or the Windows (Super on Linux) key. This setting is disabled by default.

To enable this setting you need to disable the  and 

 settings by running the following commands:

If sudo is used, it will go to the system settings.

sudo defaults write "/Library/Preferences/com.teradici.Teradici PCoIP 
Client.plist" <Key> <value>

remap_cmd_to_ctrl

mac_capture_all_keys

mac_system_shortcut_capture

defaults write "com.teradici.Teradici PCoIP Client" mac_capture_all_keys 0
defaults write "com.teradici.Teradici PCoIP Client" mac_system_shortcut_capture 0
defaults write "com.teradici.Teradici PCoIP Client" remap_cmd_to_ctrl 1

Re-boot Requirement

The macOS machine may require a re-boot for the system configuration to take effect.



Enabling remap_cmd_to_ctrl Setting
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PCoIP Client Parameters

The following table outlines command line parameters that are available to use and customize:

Short Long                                          Default Description

-? Display help message. Set to false by default.

-v Print version information. Set to false by default.

-u Username sent to Connection Broker.

-p Password sent to Connection Broker.

-d Domain sent to Connection Broker.

-b Connection broker URL.

-l Unset force log level (will override config/registry)

-w False run inside a window.

-f False run in full-screen mode. The default is to run in windowed mode.

-s Security mode.

- Set locale.

- Disable USB.

-h Hard host URL. This option is ignored if connection-broker is provided

Do no re-enter the pre-session after leaving the in-session.

Auto-forward all non-HID devices.

String of VID, PID hex values separated by spaces.

--help

--version

--username

--password

--domain

--connection-broker

--log-level

--windowed

--fullscreen

--security-mode

--locale

--disable-usb

--hard-host

--quit-after-disconnect

--usb-auto-forward

--vidpid-auto-forward

PCoIP Client Parameters
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For example, running the  command will have the following format:

Enabling Accessibility Permissions for PCoIP Client

The keyboard handling of the PCoIP Client for macOS has be updated to handle new default

handling for the CMD  key to capture and send to remote systems. In order for this new keyboard

handling to function, the PCoIP Client application must be authorized under System Preferences >

Security & Privacy > Accessibility, not authorizing the application will result in the Keyboard not

functioning in a PCoIP session. 

Short Long                                          Default Description

Blocks specific VID,PIDs from autoforward regardless of whether the 

 parameter or the USB dialog is used.

Disables the PCoIP Client menubar. Prevents the user from accessing

menu functionality.

Disables session hot keys.

Activates full-screen mode from windowed mode in a PCoIP Session.

Locks the resolution of your host application displays.

Enables scaling on the PCoIP Client without having to specify the

desktop resolution.

Maintains the aspect ratio between the host and client.

Sets the resolution of the client monitor to the native resolution when

the session client's launched .

Enables users to select which desktop they which to use.

--vidpid-black-list

usb-auto-forward

--disable-menubar

--disable-hotkeys

--full-screen

--set-host-resolution

--enable-scaling

--maintain-aspect-ratio

--force-native-

resolution

--desktop

--help

$ /Applications/PCoIPClient.app/Contents/MacOS/PCoIPClient --help

Enabling Accessibility Permissions for PCoIP Client
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When the PCoIP Client is opened for the first time on a Mac it should prompt the user to authorize

the Accessibility permission. This requires the user to accept the prompt and enter the password.

If this is declined, the prompt will not appear again and the Accessibility permission must be

configured manually from within System Preferences.

The following steps outline how to manually set the accessibility permission:

1. Open System Preferences.

2. Click on Security & Privacy.

3. Select the Privacy tab.

4. Select the Accessibility option.

5. Click the Lock icon on the bottom left corner and authenticate using your password or touch

ID.

6. Click the check mark beside PCoIP Client as outlined in the image below.

Enabling Accessibility Permissions for PCoIP Client
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Customizable Session Features

The following PCoIP session features can be customized:

• Session Menu Bar Visibility

• Disable Hot Keys

• Windowed or Fullscreen Mode

• Set Host Resolution

• Image Scaling

• Maintain Aspect Ratio

Customizable Session Features
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• PCoIP Client Keyboard Handling

Session Menu Bar Visibility

To enhance the user experience the PCoIP Session Client enables the menu bar by default,

however some use cases may require that it be disabled, or hidden, in order to prevent the user

from accessing menu functionality. To disable the menu bar feature use the parameter disable-

menubar .

Disable Hot Keys

To improve usability, session hot keys, such as Ctrl+Delete+F12 (which disconnects a PCoIP

session) are available to users by default. The parameter for this feature is disable-hotkeys .

Windowed or Fullscreen Mode

Depending on your application needs, you can display the PCoIP session in either windowed or

fullscreen mode. Fullscreen mode allows the display topology to support multiple monitors as an

extended desktop; windowed mode gives you the flexibility to display multiple application windows

in parallel and switch between them quickly. Windowed mode improves the user experience, as

well as resulting in an increase in performance. Windowed mode is the default mode, and to

activate fullscreen mode use the full-screen  parameter.

Set Host Resolution

Normally, the session client opens with arbitrary window dimensions. In some cases, you may

wish to lock the resolution of your host application displays. This ensures the user’s viewing

Examples show command-line usage

Some of the examples shown here invoke the PCoIP Software Client via the command line. You can also set these

priorities when invoking the PCoIP Software Client programmatically.
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experience is consistent across different monitors and their native resolutions. The parameter for

this feature is set-host-resolution .

• Host Resolution Limitations: It is only possible to specify one target resolution for all displays.

The host resolution will not perform to its optimal capability if you have monitors with different

resolutions.

Image Scaling

The image scaling feature enables scaling on the client without having to specify the desktop

resolution. You can apply image scaling when the resolution of the client monitor is not the same

as the resolution provided by the host. This feature provides a smoother process for image scaling

on the client. The parameter for this feature is enable-scaling .

Maintain Aspect Ratio

If the host and client aspect ratios do not match, and this parameter is not used then the display

will be stretched to fit. The parameter for this feature is maintain-aspect-ratio . If the native

aspect ratios of the host’s display and the client’s display do not match, the host’s aspect ratio will

be preserved and will appear in the client with black bars either on the sides or top and bottom of

the display.

PCoIP Client Keyboard Handling

When the PCoIP Software Client for macOS is the foreground application it will capture system

level keyboard shortcuts such as CMD + TAB  and CMD + SPACE  and send them to the remote

machine. This is enabled by default with the  OS setting which

you need to set in the com.teradici.Teradici PCoIP Client.plist file. These shortcuts will no longer

be actioned on the local machine when the PCoIP Software Client for macOS is in focus. The CMD

key will no longer be mapped to the CTRL  key even if the  setting is enabled

and set in the com.teradici.Teradici PCoIP Client.plist file. You will need to enable accessibility

permissions on the PCoIP Client in order for the keyboard to function with these changes.

Instructions for how to enable these permissions are outlined above.

The  setting captures all keys and modifiers on the PCoIP Software Client

system when the PCoIP Software Client for macOS is in focus, except for the Fn  keys when they

mac_system_shortcut_capture

remap_cmd_to_ctrl

mac_capture_all_keys

Image Scaling
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are enabling special functions, such as keyboard brightness, volume, etc. This setting is enabled

by default.

The  setting is a pre-existing setting which controlled whether the command

key would map to Control, or the Windows (Super on Linux) key. This setting is disabled by default.

It can be enabled if necessary by first disabling the  and 

 setting.

Launching PCoIP Software Client with a URI

It is possible to launch the PCoIP Software Client with a URI. The Teradici URI uses JSON Web

Tokens (JWT). For more information on the use of JWT, see here. The URI is defined as the

following:

When additional parameters are passed through the encoded JWT a session can be launched:

The table below details supported optional JWT payload claims:

remap_cmd_to_ctrl

mac_system_shortcut_capture

mac_capture_all_keys

pcoip://[broker]/connect[?data={jwt}]

Field Description Optional vs

Required

pcoip:// Scheme registered to operating system so that PCoIP Client can be

launched

Required

broker Broker through which a pcoip session is supposed to be brokered through Optional

/

connect

Connecting to a PCoIP Client with the parameters defined in "?data" Required

?data Query parameter to store a jwt encoded user credentials Optional

Claim Description

usr Username

dom Domain

Launching PCoIP Software Client with a URI
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Below is an example of a JWT payload:

The following is an example of a connect command:

Claim Description

vm Virtual machine/resource name

sid Broker JSESSIONID

{
    "usr": "username",
    "dom": "mydomain.com",
    "vm": "mydesktopname"
}

pcoip://fake.broker.com/connect?
data=eyJhbGciOiJIUzI1NiIsInR5cCI6IkpXVCJ9.eyJ1c3IiOiJ1c2VybmFtZSIsImRvbSI6Im15ZG9tYWluLmNvbSIsInZtIj

Launching PCoIP Software Client with a URI
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PCoIP High Performance Client

The PCoIP Software Client for macOS has a high performance mode that can be enabled using 

com.teradici.Teradici PCoIP Client.plist. The PCoIP High Performance Client is for use in

specialized workflows, where higher frame rates, fewer dropped frames and PCoIP Ultra AV-Lock

would be beneficial. See PCoIP Ultra for details.

To enable the high performance mode of the PCoIP Software Client for macOS, add the following

key/value pair to com.teradici.Teradici PCoIP Client.plist using the following command:

Once this key/value pair has been added, restart the PCoIP Client and connect to a PCoIP Graphics

Agent to use the high performance mode.

For further details about using com.teradici.Teradici PCoIP Client.plist, and how to apply settings

for all user's, refer to System Precedence.

Statistics Overlay on the High Performance Client

The statistics overlay feature on the High Performance Client displays the following information:

• Codec: This reports the current PCoIP encoding that is in use. Possible values for this include

PCoIP Ultra CPU, PCoIP Ultra GPU and PCoIP.

• Encoding: This reports the color space that is being used to encode the information. PCoIP

and PCoIP Ultra CPU offload will report RGB 8:8:8 which means full 8 bit RGB pixels are being

PCoIP High Performance Client Limitations

The PCoIP High Performance Client is recommended for customers wishing to optimize the presentation of high

frame rate content such as video or animations. Teradici does not recommend using the PCoIP High Performance

Client for the majority of use cases, and instead it is a case specific enhancement at this time, as it contains certain

limitations. PCoIP High Performance Client for macOS is currently only supported on Intel hardware. Apple Silicon

(M1) is not currently supported. 



defaults write "com.teradici.Teradici PCoIP Client" enable_high_perf_client 1

PCoIP High Performance Client
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used. For PCoIP Ultra GPU optimization, either YUV 4:4:4 or YUV 4:2:0 will be used, depending

on the system configuration.

• HW Decode: This reports whether or not the PCoIP Client is decoding the frames using built-in

GPU hardware decoding.

• FPS: This reports the current frames per second that are presented on the PCoIP Client.

The image below is an example of a statistics overlay on the High Performance Client: 

You can enable the statistics overlay of the High Performance Client from the View menu on the

PCoIP Client and clicking the Statistics Overlay menu item. A checkmark beside the menu item

will indicate if the feature is enabled. 

Statistics Overlay on the High Performance Client
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Custom Logo in Pre-Session

The PCoIP Software Client can be configured to place a custom logo beside the PCoIP logo at the

bottom right corner of the PCoIP Software Client login dialog. For best results, the logo should be a

.png file with a transparent background, and ideally should be 245x100 or smaller. The image must

be named customlogo.png.

• macOS location: ~/Library/Preferences/Teradici/PCoIPClient/

Custom Logo in Pre-Session
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HID Local Termination Blacklist

Local Termination of Wacom tablets provides the best user experience in networks with high

latency, however some features of the tablet may not be fully supported with local termination. A

HID local termination blacklist has been added to override the preferred local termination mode. 

Devices on the blacklist would be bridged to the remote desktop. To enable the HID local

termination blacklist, add the following setting to com.teradici.Teradici PCoIP Client.plist. For

information on the commands to use with .plist files, see the System Precedence section. The

vendor and product IDs are separated by a comma and multiple devices are separated by a space.

Troubleshooting HID Local Termination Blacklist

The following lines should appear in the PCoIP Agent log if a device is using HID local termination:

localtermination_black_list "0123,abcd 5678,1a3b" 

pcoip server log: `LVL:2 RC: 0 MGMT_KMP :Client added HoIP device (id:0x000a0005) 
with vendor id=0x056a, product id=0x0391`
pcoip client log: `LVL:2 RC: 0 MGMT_USB :HoIP supported device detected (Vid: 
0x056a, Pid: 0x0391), using HoIP protocol for local termination'

HID Local Termination Blacklist
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PCoIP Software Client Security Modes

The PCoIP Software Client uses certificates to verify the identity of the host to which it connects.

The security mode is configured by the  setting in the Teradici PCoIP Client

configuration file, which is described next. Three security mode options are available:

• security_mode=0: verification is not required A red, unlocked padlock icon appears on the

client login screen.

• security_mode=1: warn but allow (default) If a certificate cannot be verified, an 'untrusted

server' warning displays and a red, unlocked padlock icon appears on the client login screen.

Users still have the option of connecting.

This mode is used if  is not set in the configuration file.

• security_mode=2: full verification is required Users cannot connect unless a certificate can be

verified.

Setting the Security Mode

Use the following procedure to set the PCoIP Software Client's security mode.

To set the security mode for the PCoIP Software Client:

1. Close the PCoIP Software Client.

2. Open a terminal window and type the following command at the command line:

security_mode

security_mode

PCoIP sessions are always encrypted

Your PCoIP session is still encrypted and secure if you connect with security mode 0 or 1. The red padlock icon

indicates that the certificate presented by the host is not signed by a trusted certificate authority in the client’s

certificate store, not that the session is insecure.



sudo defaults write "com.teradici.Teradici PCoIP Client" security_mode <value>

PCoIP Software Client Security Modes
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where is your desired security option (0, 1, or 2). This command is for system wide scope,

please refer to the System Precedence section for further information on systems scope.

value

Reboot May Be Required

After running the above command, you may be required to reboot your machine for this change to take effect.



Setting the Security Mode
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Installing the Internal Root CA Certificate in a PCoIP
Client

Your root CA certificate must be installed in any PCoIP client that will be used to connect to the

PCoIP Agent.

Installing Root CA Certificates in the PCoIP Software Client for macOS

In macOS, certificates are stored in the Keychain Access application.

To import your root CA certificate in the PCoIP Software Client for macOS:

1. Copy your root CA certificate file (*.crt) to the Mac client desktop.

2. Double-click Applications > Utilities Keychain Access.app to open Keychain Access.

3. Select File > Import Items.

4. Navigate to the desktop and then select your root CA certificate.

5. In the Destination Keychain drop-down menu, select System, and then click Open.

6. If prompted, enter your Keychain Access password and then click Modify Keychain.

7. At the next screen, click Always Trust when asked whether you want your computer to trust

certificates signed by this certificate.

8. If prompted, enter your Keychain Access password and then click Update Settings.

After the certificate installs successfully, it appears in the System > Certificates list.

Important: Root CA Certificate must have a .crt extension

You must change the root CA certificate's extension from .pem to .crt before installing it on a PCoIP Software

Client.



Installing the Internal Root CA Certificate in a PCoIP Client
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Contacting Support

If you encounter problems installing or using Teradici technology, you can:

• Check for updated release notes, which may address the issue you are experiencing. Release

notes are published on Teradici Support.

• Browse the Teradici Knowledge Base.

• Submit a support ticket.

Contacting Support
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The Teradici Community Forum

The PCoIP Community Forum allows users to have conversations with other IT professionals to

learn how they resolved issues, find answers to common questions, have peer group discussions

on various topics, and access the Teradici PCoIP Technical Support Service team. Teradici staff

are heavily involved in the forums.

To join the Teradici community, visit the Teradici Community Forum.

The Teradici Community Forum
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Creating a Technical Support File

Teradici may request a support file from your system in order to troubleshoot and diagnose PCoIP

issues.

The support file is a tar.gz archive containing PCoIP Software Client for macOS logs and other

diagnostic data that can help support diagnose your problem.

To create a support file:

1. Open a terminal window.

2. Launch the support bundler:

The file will be created and placed in the user's home directory.

sudo /Applications/PCoIPClient.app/Contents/Resources/pcoip-client-support-bundler

Creating a Technical Support File
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Troubleshooting USB Devices

The following sections outline potential issues and workarounds that may occur with USB Devices

on the PCoIP Software Client for macOS.

USB Kernel Extension

If the USB kernel extension file, usb-mediator.kext, fails to load, run the following commands to

resolve the issue:

1. Open a terminal shell and run: 

2. Then run the following command: 

3. Finally clear the kextcache by running the following command: 

USB Device Pressure Sensitivity

The PCoIP Software Client for macOS may encounter issues with Wacom pressure sensitivity.

This is as a USB handling restriction on macOS Catalina. It occurs when you want to load the USB

Kernel Extension at session start up. The following workaround can be used on OSX Catalina to

enable kext (Kernel extension) specifically:

1. Run the following command: 

sudo chmod -R 755 /Applications/PCoIPClient.app/Contents/MacOS/usb-
mediator.kext

sudo chown -R root:wheel /Applications/PCoIPClient.app/Contents/MacOS/usb-
mediator.kext

sudo kextcache --clear-staging

sudo kextload /Applications/PCoIPClient.app/Contents/MacOS/usb-mediator.kext

Troubleshooting USB Devices
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2. You will receive the following error: 

3. Open your System Preferences.

4. Select Security and Privacy.

5. Select the General tab and you will be asked to approve the kext from Teradici.

6. Approve the kext and the device will be visible and available as a connection in the client.

/Applications/PCoIPClient.app/Contents/MacOS/usb-mediator.kext failed to 
load - (libkern/kext) system policy prevents loading; check the system/
kernel logs for errors or try kextutil(8)`

Wacom Tablet Connection

Another common problem that user's are running into that causes pressure sensitivity is they are not connecting the

Wacom tablet to the remote workstation. It is important to understand that even if you are using a Wacom table that

supports local termination, you need to connect the Wacom table to the remote workstation.



USB Device Pressure Sensitivity
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Checking the PCoIP Software Client Software
Release

The PCoIP Software Client pre-session window contains an About button in the lower left of the

window. Click this button and then select About from the popup menu to display the PCoIP

Software Client software release version.

From either client, you can also select the Teradici PCoIP Client > About Teradici PCoIP Client

menu to display the software release version from within a PCoIP session.

Checking the PCoIP Software Client Software Release
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About menu item only appears when the client is in session

The About Teradici PCoIP Client menu item only appears when the client is in session. The menu item is not available

from the pre-session GUI.



Checking the PCoIP Software Client Software Release
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Troubleshooting Your PCoIP Software Client

This section demonstrates using PCoIP Software Client log files to troubleshoot problems you

may encounter with your PCoIP Software Client.

PCoIP Software Client logs are text (.txt) files that contain system and session information about

your connection. They are useful for troubleshooting problems. A new log file is created each time

you use a PCoIP Software Client to initiate a PCoIP session.

Client logs are placed in .

If you experience a problem, recreate the issue, generate a support bundle and contact Teradici

Support. You can also check the Teradici PCoIP Community Forum for troubleshooting

information about this product.

~/Library/Logs/Teradici/PCoIPClient

Troubleshooting Your PCoIP Software Client
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Session Log IDs

The PCoIP Software Client creates a unique session ID when a new session is established, and

distributes that ID to all components in the system. When PCoIP components generate log

messages, they are prefixed by this unique session ID, allowing administrators and support to

easily group events by session across multiple components:

For example:

Log messages that do not pertain to a specific session will show a string of zeroes in place of the

session log ID number.

yyyy-mm-ddThh:mm:ss.ffffffZ xxxxxxxx-xxxx-xxxx-xxxx-xxxxxxxxxxxx > …

2015-11-06T08:01:18.688879Z 4208fb66-e22a-11d1-a7d7-00a0c982c00d > …

Session Log IDs
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Setting Log Levels

You can set log levels to determine the level of details provided in the log. Log levels range from 0

to 3, where 0 provides the least information and 3 provides the most information.

To set log levels:

•  where  is lowercase L and  is

desired the log level (1, 2, or 3).

You can also set the log level persistently in the ~/.pcoip.rc file. This file should contain the

following line to set the log level to 3:

To revert back to the default log level, remove this line from the file.

open /Applications/PCoIPClient.app --args -l x l x

pcoip.event_filter_mode = 3

Setting Log Levels

© 2021 Teradici 87



Locating PCoIP Software Client for macOS Log
Files

On a Mac computer, PCoIP Software Client log files are located within the user’s Home Library

folder, which is hidden by default. The recommended way to access Home Library files is to use

the macOS Console.

You can also display log files in a macOS terminal window.

To display log files using the macOS Console:

1. To open the Console, go to the Applications > Utilities folder, and then double-click Console.

2. In the FILES section of the Log List pane on the left, navigate to the following folder: 

3. Select the desired log file to view its contents in the main pane.

4. To copy the contents:

• Click anywhere in the log contents, and then select Edit > Select All.

• Select Edit > Copy.

• Paste the contents into an email or text file.

To display log files in a macOS terminal window:

1. To open a terminal window, go to the Applications > Utilities folder, and then double-click

Terminal.

2. Navigate to the PCoIP Software Client log folder by typing the following command at the

command line prompt:

3. Type  to display the list of log files.

4. To view the contents of a log file, use any macOS command-line editor to open it.

5. To open a terminal window, go to the Applications > Utilities folder, and then double-click 

Terminal.

~/

Library/Logs/Teradici/PCoIPClient

cd ~/Library/Logs/Teradici/PCoIPClient

ls

Locating PCoIP Software Client for macOS Log Files
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6. Navigate to the PCoIP Software Client log folder by typing the following command at the

command line prompt:

7. Type  to display the list of log files.

8. To view the contents of a log file, use any macOS command-line editor to open it.

cd ~/Library/Logs/Teradici/PCoIPClient

ls

Locating PCoIP Software Client for macOS Log Files
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Reconnecting a PCoIP Session

If a network interruption is detected, the PCoIP session enters a reconnecting phase. In this phase

the client will show you the network reconnecting dialog which indicates that there is a network

issue and that the client is trying to reconnect and re-establish the PCoIP session. You can click 

disconnect to cancel the attempted reconnect and disconnect the session completely. If the

reconnection is successful, the notification dialog will disappear and the session will be restored, if

not, the session will be disconnected completely.

Reconnecting a PCoIP Session
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Microphone Access on MacOS Catalina 10.15

On MacOS Catalina 10.15 you are required to enable access to the microphone before audio input

works. The following steps outline how to enable this access:

1. Go to System Preferences.

2. Click Security & Privacy.

3. Click on the Privacy control panel.

4. From the left side menu click Microphone.

5. Ensure that the PCoIPClient application has a checkmark. This indicates that the application is

allowed to use the microphone.

Unlocking Control Panel

To make a change in the control panel you need to ensure that the panel is unlocked by clicking the lock icon on the

control panel.



Microphone Access on MacOS Catalina 10.15
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Mapping Function Keys

You can enable Function keys on the PCoIP Software Client for macOS by going to Apple>System

Preferences>Keyboard and selecting the function keys you wish to use as standard keys. When

the system is configured to not use function keys the PCoIP Software Client does not get the

function key codes from the system when the keys are pressed. In this instance the function keys

are usd for other system features such as turning the volume up and down. 

Mapping Function Keys
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Capturing Keyboard Keys

The PCoIP Software Client for macOS captures all keys and redirects them to the remote machine

with the following exceptions:

• PCoIP Client short cuts appearing under the Connection and View menus.

• Function Keys (F1 to F12) when in system mode.

• The Eject and Power keys.

When the PCoIP Sessions starts, and the PCoIP Client is the focused foreground application, all

keys, apart from from those outlined above, will be redirected to the remote machine.

Key Combinations Access Permissions

You need to grant accessibility in order for the PCoIP Client to be able to forward all possible keyboard combinations

to the remote workstation. This permission can be enabled in the Security and Privacy tab on the macOS, as outlined

in the screenshot below.
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